From our previous posts (the Kodi 17 FAQ and Kodi 17 or Bust?), we know that Kodi 17 requires Android 5 or higher. ...